Go Back   Scale 4x4 R/C Forums > Monsters, Scale 4X2, & Non scale R/C > Rock Crawlers
Make payments with PayPal - it's fast, free and secure!

Rock Crawlers For those Rock crawling, stone sliding, body scratching, articulation crackheads; this place is for you!


Reply
 
Thread Tools Display Modes
  #1  
Old 02-04-2015, 02:19 PM
iblis iblis is offline
Newbie
 
Join Date: Oct 2009
Posts: 5
Member Number: 9514
B/S/T Feedback: (0)
Default broken ESC I guess

I have a broken ESC (more likely) or brushless sensor motor.
I just had it back from store yesterday. and it is defunct again.
the motor is not turning at all. but at shop & before I put it back into the unimog, it's running.
any idea how to fix it?
it's Chinese brand skyrc.
I m pretty sure the rx and tx is working properly since I have tried on my trf 419
I did a calibration several times already.
Reply With Quote
Sponsored Links


The sponsored ad above is only displayed to guests. Creat an account today to remove this ad!
  #2  
Old 02-05-2015, 12:19 AM
iblis iblis is offline
Newbie
 
Join Date: Oct 2009
Posts: 5
Member Number: 9514
B/S/T Feedback: (0)
Default

I just unscrew and open the motor and put it back. it's running now.
however, I can't tighten up the screw
no idea. the wiring is probably wrong. but i don't know how to fix it. it has to be reverse the throttle to make it working
Reply With Quote
  #3  
Old 02-05-2015, 03:17 AM
iblis iblis is offline
Newbie
 
Join Date: Oct 2009
Posts: 5
Member Number: 9514
B/S/T Feedback: (0)
Default

no idea what going wrong.
the motor is dead after running 2-3sec.
after switch off and on the esc, the motor goes live again.
Reply With Quote
  #4  
Old 03-03-2016, 06:59 PM
dgonslayer's Avatar
dgonslayer dgonslayer is offline
Newbie
 
Join Date: Dec 2010
Posts: 46
Member Number: 13630
B/S/T Feedback: (1)
Default

just seen this topic are u talking bout the 120 amp unit if so i have one an its been great if the motor screws are to long use cople washers or cut them bit shorter on the deal where it stops working check the plugs on esc that run to motor i had to clip the ends an re tin the wires guess they used crappy solder also u can use the hobbywing programer on it
Reply With Quote
  #5  
Old 04-20-2017, 01:28 PM
owlsarepretty103 owlsarepretty103 is offline
Newbie
 
Join Date: Apr 2017
Posts: 10
Member Number: 25446
B/S/T Feedback: (0)
Default

I thank you for the information! I was looking for and could not find. You helped me!
myhr cvs

Last edited by owlsarepretty103 : 06-27-2017 at 07:08 PM.
Reply With Quote


Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 02:24 PM.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2004 - 2017, Scale 4x4 R/C